QuickBooks, Vista and Windows 7

Filed Under (QuickBooks) by moirapottow on 03-04-2010

Tagged Under : , ,

PLEASE NOTE: All Versions of QuickBooks  2006  and prior are not compatible with Microsoft Vista and Microsoft Windows 7. Many forums say that it can be done, but my experience is that a lot of problems arise down the line (especially when you get windows updates). To avoid any frustration, if you would like to  upgrade your computer and operating system, I suggest your upgrade Quickbooks as well to versions 2008 or 2010 (which will be launched in the next few months). Please contact me on moirapottow@mweb.co.za